Ipopt incompatibility with gcc 4.8.3

The following error may occur when compiling Bocop for the first time on Linux:

error: #error "don't have function for random number generator"

It is caused by an incompatibility between Ipopt 3.11.8 and gcc 4.8.3.

We will release a new version of Bocop that fix that problem. Meanwhile, to fix it, you can compile Ipopt yourself by executing the following commands:

cd <BOCOP>/ThirdParty/Ipopt-3.11.8
./configure --prefix=<BOCOP>/ThirdParty/Ipopt-3.11.8/ --enable-static coin_skip_warn_cxxflags=yes
make -j
make install

where <BOCOP> is the absolute path to the install directory of Bocop (the one in which you have extracted the package).

Comments are closed